SpotBeamAngle Property


Spot Light Distribution Spot Beam Angle Property

The spot beam angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double SpotBeamAngle { get; set; }

Property Value

Double
The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The angle is not valid because it is not between 1.0e-2 and 160.0.
See Also