Validates that the element is eligible for a solid-solid cut.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The solid to be cut or the cutting solid.
Return Value
True if the input element can participate in a solid-solid cut. False otherwise.Remarks
The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |