Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- brepBuilderGeometryId
- Type: Autodesk.Revit.DB BRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.
Return Value
True if the input BRepBuilderGeometryId represents the ID of either a Face or an Edge, false otherwise.Remarks
This method returns false also in the case when the associated BRepBuilder is not valid. Call IsAssociatedBRepBuilderValid to check the associated BRepBuilder.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |