BRep |
Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsBRepBuilderGeometryIdFaceOrEdge(
BRepBuilderGeometryId brepBuilderGeometryId
)
Parameters
- brepBuilderGeometryId BRepBuilderGeometryId
- The BRepBuilderGeometryId to be used in a new correspondence.
Return Value
BooleanTrue if the input BRepBuilderGeometryId represents the ID of either a Face or an Edge, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This method returns false also in the case when the associated BRepBuilder is not valid. Call IsAssociatedBRepBuilderValid to check the associated BRepBuilder.