Used in operations to specify the primitive type of an IFCData.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Integer | Integer. |
Double | Double. |
Boolean | Boolean. |
Logical | IFCLogical type. |
String | String. |
Binary | Binary. When reading or writing an IFCData of primitive type Binary, the value will be the string representation of the binary value as seen in the IFC specification. |
Enumeration | Enumeration. When reading or writing an IFCData of primitive type Enumeration, the value will be the string representation of the enumeration value as seen in the IFC specification. |
Instance | Represents IFCAnyHandle. |
Aggregate | Represents IFCAggregate. |
Unknown | Unknown. |