IFCDataPrimitiveType Enumeration


IFCData Primitive Type Enumeration

Used in operations to specify the primitive type of an IFCData.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum IFCDataPrimitiveType
Members
Member name Value Description
Aggregate 8 Represents IFCAggregate.
Binary 5 Binary. When reading or writing an IFCData of primitive type Binary, the value will be the string representation of the binary value as seen in the IFC specification.
Boolean 2 Boolean.
Double 1 Double.
Enumeration 6 Enumeration. When reading or writing an IFCData of primitive type Enumeration, the value will be the string representation of the enumeration value as seen in the IFC specification.
Instance 7 Represents IFCAnyHandle.
Integer 0 Integer.
Logical 3 IFCLogical type.
Number 10 Number.
String 4 String.
Unknown 9 Unknown.
See Also