Sets curve loops that define geometry of the area load.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document that contains the area load.
- newLoops
- Type: System.Collections.Generic IList CurveLoop
Loops that define new geometry of the area load. The curve loop collection should contains a closed loops consisting of lines.
Return Value
Returns true if successful, false otherwise.Remarks
This method works with non hosted area load only. All previously defined reference points will be removed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when newLoops collection is empty. -or- Thrown when newLoops contains open loop. -or- Thrown when newLoops contains a loop consisting of other elements then lines. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |