SetLoops Method


Area Load Set Loops Method

Sets curve loops that define geometry of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetLoops(
	Document doc,
	IList<CurveLoop> newLoops
)

Parameters

doc Document
The document that contains the area load.
newLoops IList CurveLoop
Loops that define new geometry of the area load. The curve loop collection should contains a closed loops consisting of lines.

Return Value

Boolean
Returns true if successful, false otherwise.
Exceptions
Exception Condition
ArgumentException One of the following requirements is not satisfied : - curve loops newLoops are not planar - curve loops newLoops are self-intersecting - curve loops newLoops contains zero length curves -or- Thrown when newLoops collection is empty. -or- Thrown when newLoops contains open loop. -or- Thrown when newLoops contains a loop consisting of other elements then lines.
ArgumentNullException A non-optional argument was null
InvalidOperationException This AreaLoad is not a hosted load. -or- This AreaLoad is a constrained load.
Remarks
This method works for loads which are not constrained to their host. This method works with hosted area load only. All previously defined reference points will be removed. Curve Loop must be planar and not self-intersecting.
See Also