Creates new system which is hydraulically separated from the existing system.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document where the new system is created.
- pipeElementIds
- Type: System.Collections.Generic ISet ElementId
The boundary pipe that defines a new system. Multiple pipes are allowed to create more than one separated systems.
Return Value
The newly created piping system elements.Remarks
Hydraulically separated systems allow independent flow and pressure analysis for each hydraulic loop. For example, each hydraulic loop has its own cirtical path. The calculated pressure drop on the primary pump is consisted of all pressure drop on the primary critical path. Any pressure drop on the secondary loop would only contribute to the calculated pressure drop of the secondary pump.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more elements is not a pipe. -or- One or more elements is already the loop boundary. -or- One or more elements can not be used as loop boundary. Check if the element connects to any junction. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |