CreateHydraulicSeparation Method


Piping System Create Hydraulic Separation Method

Creates new system which is hydraulically separated from the existing system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> CreateHydraulicSeparation(
	Document document,
	ISet<ElementId> pipeElementIds
)

Parameters

document Document
The document where the new system is created.
pipeElementIds ISet ElementId
The boundary pipe that defines a new system. Multiple pipes are allowed to create more than one separated systems.

Return Value

ISet ElementId
The newly created piping system elements.
Exceptions
Exception Condition
ArgumentException One or more elements is not a pipe. -or- One or more elements is already the loop boundary. -or- One or more elements can not be used as loop boundary. Check if the element connects to any junction.
ArgumentNullException A non-optional argument was null
Remarks
Hydraulically separated systems allow independent flow and pressure analysis for each hydraulic loop. For example, each hydraulic loop has its own cirtical path. The calculated pressure drop on the primary pump is consisted of all pressure drop on the primary critical path. Any pressure drop on the secondary loop would only contribute to the calculated pressure drop of the secondary pump.
See Also