Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- overallLength
- Type: System Double
The entire length of the wire sheet in the major direction.
- majorStartOverhang
- Type: System Double
The distance from the edge of the sheet to the first wire in the major direction.
- numberOfWires
- Type: System Int32
The number of wires in the minor direction.
- spacing
- Type: System Double
The distance between the wires in the minor direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |