SetMinorLayoutAsNumberWithSpacing Method


Fabric Sheet Type Set Minor Layout As Number With Spacing Method

Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMinorLayoutAsNumberWithSpacing(
	double overallLength,
	double majorStartOverhang,
	int numberOfWires,
	double spacing
)

Parameters

overallLength Double
The entire length of the wire sheet in the major direction.
majorStartOverhang Double
The distance from the edge of the sheet to the first wire in the major direction.
numberOfWires Int32
The number of wires in the minor direction.
spacing Double
The distance between the wires in the minor direction.
Exceptions
Exception Condition
ArgumentException The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
ArgumentOutOfRangeException The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
See Also