Gets the Wire stored in the FabricSheetType at the associated index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wireIndex
- Type: System Int32
Item index in the Fabric Sheet
- direction
- Type: Autodesk.Revit.DB.Structure WireDistributionDirection
Wire distribution direction of the inquired item
Return Value
Fabric wire ItemExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The item index is either less than 0 or greater than or equal to number of items in this FabricSheetType. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | Fabric Sheet is not Custom |