Gets the Wire stored in the FabricSheetType at the associated index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wireIndex
- Type: SystemInt32
Item index in the Fabric Sheet
- direction
- Type: Autodesk.Revit.DB.StructureWireDistributionDirection
Wire distribution direction of the inquired item
Return Value
Fabric wire ItemExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The item index is either less than 0 or greater than or equal to number of items in this FabricSheetType. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | Fabric Sheet is not Custom |