Look up a column attachment. There is at most one attachment on the base and one on the top.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- column
- Type: Autodesk.Revit.DB FamilyInstance
A column.
- baseOrTop
- Type: System Int32
0 for base, 1 for top.
Return Value
The column attachment for the base or top of the column, or a null reference ( Nothing in Visual Basic) if that end of the column is unattached.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. |