Column |
Look up a column attachment. There is at most one attachment on the base and one on the top.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ColumnAttachment GetColumnAttachment(
FamilyInstance column,
int baseOrTop
)
Parameters
- column FamilyInstance
- A column.
- baseOrTop Int32
- 0 for base, 1 for top.
Return Value
ColumnAttachmentThe column attachment for the base or top of the column, or if that end of the column is unattached.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. |