Identifies whether the given curve loops compose a valid boundary.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveLoops
- Type: System.Collections.Generic IList CurveLoop
The curve loops to be checked.
Return Value
True if the given curve loops don't intersect with each other; each curve loop is closed; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane. Any requirement above is not satisfied or no curve loops contained, returns false.Remarks
The curve loops are valid if they don't intersect with each other; each curve loop is closed; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |