Site |
Identifies whether the given curve loops compose a valid boundary.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
BooleanTrue if the given curve loops don't intersect with each other; each curve loop is closed; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane. Any requirement above is not satisfied or no curve loops contained, returns false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The curve loops are valid if they don't intersect with each other; each curve loop is closed; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane.