Enumerated type listing the type of asset property
Asset Property Types.
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Unknown | An unknown or unspecified property type. |
Properties | Represents Properties. The corresponding AssetProperty sub class is AssetProperties. |
Boolean | Represents property Boolean. The corresponding AssetProperty sub class is AssetPropertyBoolean. |
Enumeration | Represents property Enum. The corresponding AssetProperty sub class is AssetPropertyEnum. |
Integer | Represents property Integer. The corresponding AssetProperty sub class is AssetPropertyInteger. |
Float | Represents property Float. The corresponding AssetProperty sub class is AssetPropertyFloat. |
Double1 | Represents property Double. The corresponding AssetProperty sub class is AssetPropertyDouble. |
Double2 | Represents property 2d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray2d. |
Double3 | Represents property 3d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray3d. |
Double4 | Represents property 4d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray4d. |
Double44 | Represents property 4x4 Double matrix. The corresponding AssetProperty sub class is AssetPropertyDoubleMatrix44. |
String | Represents property String. The corresponding AssetProperty sub class is AssetPropertyString. |
Time | Represents property Time. The corresponding AssetProperty sub class is AssetPropertyTime. |
Distance | Represents property Distance. The corresponding AssetProperty sub class is AssetPropertyDistance. Special. |
Asset | Represents property Asset. The corresponding AssetProperty sub class is Asset. |
Reference | Represents property Reference. The corresponding AssetProperty sub class is AssetPropertyReference. |
Longlong | Represents property Int64. The corresponding AssetProperty sub class is AssetPropertyInt64. |
ULonglong | Represents property unsigned Int64. The corresponding AssetProperty sub class is AssetPropertyUInt64. |
List | Represents property List. The corresponding AssetProperty sub class is AssetPropertyList. |
Float3 | Represents property Float array. The corresponding AssetProperty sub class is AssetPropertyFloatArray. |