Asset |
Enumerated type listing the type of asset property
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
Asset | 15 | Represents property Asset. The corresponding AssetProperty sub class is Asset. |
Boolean | 2 | Represents property Boolean. The corresponding AssetProperty sub class is AssetPropertyBoolean. |
Distance | 14 | Represents property Distance. The corresponding AssetProperty sub class is AssetPropertyDistance. Special. |
Double1 | 6 | Represents property Double. The corresponding AssetProperty sub class is AssetPropertyDouble. |
Double2 | 7 | Represents property 2d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray2d. |
Double3 | 8 | Represents property 3d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray3d. |
Double4 | 9 | Represents property 4d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray4d. |
Double44 | 10 | Represents property 4x4 Double matrix. The corresponding AssetProperty sub class is AssetPropertyDoubleMatrix44. |
Enumeration | 3 | Represents property Enum. The corresponding AssetProperty sub class is AssetPropertyEnum. |
Float | 5 | Represents property Float. The corresponding AssetProperty sub class is AssetPropertyFloat. |
Float3 | 20 | Represents property Float array. The corresponding AssetProperty sub class is AssetPropertyFloatArray. |
Integer | 4 | Represents property Integer. The corresponding AssetProperty sub class is AssetPropertyInteger. |
List | 19 | Represents property List. The corresponding AssetProperty sub class is AssetPropertyList. |
Longlong | 17 | Represents property Int64. The corresponding AssetProperty sub class is AssetPropertyInt64. |
Properties | 1 | Represents Properties. The corresponding AssetProperty sub class is AssetProperties. |
Reference | 16 | Represents property Reference. The corresponding AssetProperty sub class is AssetPropertyReference. |
String | 11 | Represents property String. The corresponding AssetProperty sub class is AssetPropertyString. |
Time | 12 | Represents property Time. The corresponding AssetProperty sub class is AssetPropertyTime. |
ULonglong | 18 | Represents property unsigned Int64. The corresponding AssetProperty sub class is AssetPropertyUInt64. |
Unknown | 0 | An unknown or unspecified property type. |