Creates a Plane object defined by a local frame of reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- frameOfReference
- Type: Autodesk.Revit.DB Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the plane being constructed.- Frame.Origin is a point on plane.
- Frame.BasisZ defines the plane's normal, while Frame.BasisX and Frame.BasisY are orthogonal to the normal.
- The frame may be either left-handed or right-handed (see Frame.IsRightHanded).
Remarks
The parametric equation of the plane is S(u, v) = Frame.Origin + u*Frame.BasisX + v*Frame.BasisY. Frame.BasisZ defines the plane's normal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This Frame object may not be used as a local frame of reference. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |