Plane Create Method |
Creates a Plane object defined by a local frame of reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- frameOfReference Frame
- frameOfReference is an orthonormal frame that defines a local coordinate system for the plane being constructed.
- Frame.Origin is a point on plane.
- Frame.BasisZ defines the plane's normal, while Frame.BasisX and Frame.BasisY are orthogonal to the normal.
- The frame may be either left-handed or right-handed (see Frame.IsRightHanded).
Return Value
Plane
Exception | Condition |
---|---|
ArgumentException | This Frame object may not be used as a local frame of reference. |
ArgumentNullException | A non-optional argument was null |

The parametric equation of the plane is S(u, v) = Frame.Origin + u*Frame.BasisX + v*Frame.BasisY. Frame.BasisZ defines the plane's normal.