Creates a new instance of Tees shape.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- width
- Type: System Double
Section width.
- height
- Type: System Double
Section height, depth.
- flangeThickness
- Type: System Double
Flange Thickness.
- flangeThicknessLocation
- Type: System Double
Flange Thickness Location.
- flangeFillet
- Type: System Double
Flange Fillet - fillet radius at the flange end.
- flangeToeOfFillet
- Type: System Double
Detailing distance from center of web to flange toe of fillet, in. (mm)
- slopedFlangeAngle
- Type: System Double
Sloped flange angle. (rad)
- webThickness
- Type: System Double
Web Thickness.
- webThicknessLocation
- Type: System Double
Web Thickness Location.
- webFillet
- Type: System Double
Web Fillet - fillet radius between web and flange.
- topWebFillet
- Type: System Double
Top Web Fillet - fillet radius at the top of web.
- webToeOfFillet
- Type: System Double
Detailing distance from outer face of flange to web toe of fillet, in. (mm)
- slopedWebAngle
- Type: System Double
Sloped web angle. (rad)
- centroidHorizontal
- Type: System Double
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: System Double
Distance from centroid to the upper extremites along vertical axis.
- analysisParams
- Type: Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionAnalysisParams
Common set of parameters for structural analysis.