StructuralSectionGeneralT Constructor


Structural Section General T Constructor

Creates a new instance of Tees shape.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralSectionGeneralT(
	double width,
	double height,
	double flangeThickness,
	double flangeThicknessLocation,
	double flangeFillet,
	double flangeToeOfFillet,
	double slopedFlangeAngle,
	double webThickness,
	double webThicknessLocation,
	double webFillet,
	double topWebFillet,
	double webToeOfFillet,
	double slopedWebAngle,
	double centroidHorizontal,
	double centroidVertical,
	StructuralSectionAnalysisParams analysisParams
)

Parameters

width Double
Section width.
height Double
Section height, depth.
flangeThickness Double
Flange Thickness.
flangeThicknessLocation Double
Flange Thickness Location.
flangeFillet Double
Flange Fillet - fillet radius at the flange end.
flangeToeOfFillet Double
Detailing distance from center of web to flange toe of fillet, in. (mm)
slopedFlangeAngle Double
Sloped flange angle. (rad)
webThickness Double
Web Thickness.
webThicknessLocation Double
Web Thickness Location.
webFillet Double
Web Fillet - fillet radius between web and flange.
topWebFillet Double
Top Web Fillet - fillet radius at the top of web.
webToeOfFillet Double
Detailing distance from outer face of flange to web toe of fillet, in. (mm)
slopedWebAngle Double
Sloped web angle. (rad)
centroidHorizontal Double
Distance from centroid to the left extremites along horizontal axis.
centroidVertical Double
Distance from centroid to the upper extremites along vertical axis.
analysisParams StructuralSectionAnalysisParams
Common set of parameters for structural analysis.
See Also