Connects a pair of placeholders that can intersect in a Cross connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- placeholder1Id
- Type: Autodesk.Revit.DB ElementId
The element id of the first duct placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DB ElementId
The element id of the second duct placeholder.
Return Value
True if connection succeeds, false otherwise.Remarks
The placeholders must intersect each other. If connection succeeds, a new placeholder duct is created. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |