Mechanical |
Connects a pair of placeholders that can intersect in a Cross connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool ConnectDuctPlaceholdersAtCross(
Document document,
ElementId placeholder1Id,
ElementId placeholder2Id
)
Parameters
- document Document
- The document.
- placeholder1Id ElementId
- The element id of the first duct placeholder.
- placeholder2Id ElementId
- The element id of the second duct placeholder.
Return Value
BooleanTrue if connection succeeds, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. |
ArgumentNullException | A non-optional argument was null |

The placeholders must intersect each other. If connection succeeds, a new placeholder duct is created. If connection fails, the placeholders cannot be physically connected.