Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DB ElementId
The ElementId to be checked.
Return Value
True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.Remarks
In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |