Removes all triggers associated with specified document and Updater Does not unregister updater.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DB UpdaterId
Id of specified updater
- document
- Type: Autodesk.Revit.DB Document
Document for which to remove triggers
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveDocumentTriggers called while executing an updater. |