RemoveDocumentTriggers Method


Updater Registry Remove Document Triggers Method

Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RemoveDocumentTriggers(
	UpdaterId id,
	Document document
)

Parameters

id UpdaterId
Id of specified updater
document Document
Document for which to remove triggers
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveDocumentTriggers called while executing an updater.
See Also