NewGutter Method (GutterType, ReferenceArray)


Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public Gutter NewGutter(
	GutterType GutterType,
	ReferenceArray references
)
Visual Basic
Public Function NewGutter ( _
	GutterType As GutterType, _
	references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
	GutterType^ GutterType, 
	ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.DB ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise a null reference ( Nothing in Visual Basic) .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown if the gutter type does not exist in the given document.

See Also