Document New |
Creates a gutter along a reference array.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- GutterType GutterType
- The type of the gutter to create
- references ReferenceArray
- An array of planar lines and arcs that represents the place where you want to place the gutter.
Return Value
GutterIf successful a new gutter object within the project, otherwise .

Exception | Condition |
---|---|
ArgumentException | Thrown if the gutter type does not exist in the given document. |