GetLabelForBuiltInParameter Method (ForgeTypeId)


Gets the user-visible name for a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)

Syntax

C#
public static string GetLabelForBuiltInParameter(
	ForgeTypeId parameterTypeId
)
Visual Basic
Public Shared Function GetLabelForBuiltInParameter ( _
	parameterTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForBuiltInParameter(
	ForgeTypeId^ parameterTypeId
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the built-in parameter cannot be found.

See Also