Highlights the specified RebarConstrainedHandle and RebarConstraint in all views.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
- handle
- Type: Autodesk.Revit.DB.Structure RebarConstrainedHandle
The RebarConstrainedHandle to be highlighted in all views.
- constraint
- Type: Autodesk.Revit.DB.Structure RebarConstraint
The RebarConstraint to be highlighted in all views.
Remarks
This method is provided as a way to help end users visualize more easily the effect that selecting new RebarConstraints for the Rebar element's RebarConstrainedHandle will have on the Rebar. It is purely for graphical output, and does not assume any relationship between the RebarConstrainedHandle and the RebarConstraint. The caller is responsible for updating (or clearing) the highlighting in response to changes in the Rebar's constraints. Repeated calls to this method are not cumulative; highlighting from previous calls will be cleared before new highlighting is applied.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | constraint is no longer valid. -or- handle is no longer valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |