Rebar |
Highlights the specified RebarConstrainedHandle and RebarConstraint in all views.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void HighlightHandleConstraintPairInAllViews(
Document aDoc,
RebarConstrainedHandle handle,
RebarConstraint constraint
)
Parameters
- aDoc Document
- handle RebarConstrainedHandle
- The RebarConstrainedHandle to be highlighted in all views.
- constraint RebarConstraint
- The RebarConstraint to be highlighted in all views.

Exception | Condition |
---|---|
ArgumentException | constraint is no longer valid. -or- handle is no longer valid. -or- The handle should have the default behavior. -or- The constraint should be for handle with default behavior. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |

This method is provided as a way to help end users visualize more easily the effect that selecting new RebarConstraints for the Rebar element's RebarConstrainedHandle will have on the Rebar. It is purely for graphical output, and does not assume any relationship between the RebarConstrainedHandle and the RebarConstraint. The caller is responsible for updating (or clearing) the highlighting in response to changes in the Rebar's constraints. Repeated calls to this method are not cumulative; highlighting from previous calls will be cleared before new highlighting is applied.