Deletes hydraulically separated systems and merges the system components into the connected system.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document where the system is deleted.
- pipeElementIds
- Type: System.Collections.Generic ISet ElementId
The boundary pipe that separates the system. Multiple pipes are allowed to delete more than one separated systems.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more elements is not a pipe. -or- One or more elements is not a valid loop boundary. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |