DeleteHydraulicSeparation Method


Piping System Delete Hydraulic Separation Method

Deletes hydraulically separated systems and merges the system components into the connected system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void DeleteHydraulicSeparation(
	Document document,
	ISet<ElementId> pipeElementIds
)

Parameters

document Document
The document where the system is deleted.
pipeElementIds ISet ElementId
The boundary pipe that separates the system. Multiple pipes are allowed to delete more than one separated systems.
Exceptions
Exception Condition
ArgumentException One or more elements is not a pipe. -or- One or more elements is not a valid loop boundary.
ArgumentNullException A non-optional argument was null
See Also