Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterRules
- Type: System.Collections.Generic IList FilterRule
The rules applied to test if the element passes this filter.
- inverted
- Type: System Boolean
True if the filter should match all elements which do not pass the filter rules.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The filterRules array is empty or invalid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |