ElementParameterFilter Constructor (IList(FilterRule), Boolean)


Element Parameter Filter(IList Filter Rule , Boolean) Constructor

Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementParameterFilter(
	IList<FilterRule> filterRules,
	bool inverted
)

Parameters

filterRules IList FilterRule
The rules applied to test if the element passes this filter.
inverted Boolean
True if the filter should match all elements which do not pass the filter rules.
Exceptions
Exception Condition
ArgumentException The filterRules array is empty or invalid.
ArgumentNullException A non-optional argument was null
See Also