Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pFamInstWallElem
- Type: Autodesk.Revit.DB FamilyInstance
The in-place wall instance.
Return Value
The in-place wall geometry. Returns a null reference ( Nothing in Visual Basic) if there is no special geometry for the wall needed for export; the standard geometry of the wall can be used.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |