GetGeometryFromInplaceWall Method


Exporter IFCUtils Get Geometry From Inplace Wall Method

Obtains a special snapshot of the geometry of an in-place wall element suitable for export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static GeometryElement GetGeometryFromInplaceWall(
	FamilyInstance pFamInstWallElem
)

Parameters

pFamInstWallElem FamilyInstance
The in-place wall instance.

Return Value

GeometryElement
The in-place wall geometry. Returns if there is no special geometry for the wall needed for export; the standard geometry of the wall can be used.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also