Set structural section in element.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the family for beam, brace or structural column.
- familySymbolId
- Type: Autodesk.Revit.DB ElementId
ID of family symbol for beam, brace or structural column.
- structuralSection
- Type: Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Structural section with values that will be set.
Return Value
True is returned when requested shape with values was properly set. Return false otherwise.Remarks
Only beams, braces and structural columns can have structural section associated with it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |