SetStructuralSection Method


Structural Section Utils Set Structural Section Method

Set structural section in element.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool SetStructuralSection(
	Document document,
	ElementId familySymbolId,
	StructuralSection structuralSection
)

Parameters

document Document
The document that owns the family for beam, brace or structural column.
familySymbolId ElementId
ID of family symbol for beam, brace or structural column.
structuralSection StructuralSection
Structural section with values that will be set.

Return Value

Boolean
True is returned when requested shape with values was properly set. Return false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Only beams, braces and structural columns can have structural section associated with it.
See Also