Creates a new ParameterFilterElement in the given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDocument
- Type: Autodesk.Revit.DB Document
The document in which to create the ParameterFilterElement.
- name
- Type: System String
The user-visible name for the new ParameterFilterElement.
- categories
- Type: System.Collections.Generic ICollection ElementId
The categories for the new ParameterFilterElement.
- elementFilter
- Type: Autodesk.Revit.DB ElementFilter
The rules for the new ParameterFilterElement, represented as an ElementFilter. ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:- Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
- Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
- Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Return Value
A pointer to the new ParameterFilterElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The ElementFilter is not acceptable for use by a ParameterFilterElement. |