Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sequence
- Type: System.Collections.Generic IList String
The sequence. The sequence strings cannot contain commas.
Remarks
If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Input sequence contains invalid entries. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |