SetSequence Method


Alphanumeric Revision Settings Set Sequence Method

Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSequence(
	IList<string> sequence
)

Parameters

sequence IList String
The sequence. The sequence strings cannot contain commas.
Exceptions
Exception Condition
ArgumentException Input sequence contains invalid entries.
ArgumentNullException A non-optional argument was null
Remarks

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

See Also