Checks whether input hub is valid for an AnalyticalLink.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
Hubs's document.
- hubId
- Type: Autodesk.Revit.DB ElementId
Hub to test for validity.
Return Value
True is returned when provided hubId points hub that is valid for AnalyticalLink, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |