ConvertFromInternalUnits Method (Double, ForgeTypeId)


Converts a value from Revit's internal units to a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014

Syntax

C#
public static double ConvertFromInternalUnits(
	double value,
	ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function ConvertFromInternalUnits ( _
	value As Double, _
	unitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double ConvertFromInternalUnits(
	double value, 
	ForgeTypeId^ unitTypeId
)

Parameters

value
Type: System Double
The value to convert.
unitTypeId
Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the desired unit.

Return Value

The converted value.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also