ConvertFromInternalUnits Method (Double, ForgeTypeId)


Unit Utils Convert From Internal Units Method

Converts a value from Revit's internal units to a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static double ConvertFromInternalUnits(
	double value,
	ForgeTypeId unitTypeId
)

Parameters

value Double
The value to convert.
unitTypeId ForgeTypeId
Identifier of the desired unit.

Return Value

Double
The converted value.
Exceptions
Exception Condition
ArgumentException The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
See Also