Checks whether a symbol is valid for a given unit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the unit.
- symbolTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the symbol to check.
Return Value
True if the symbol is valid, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |