IsValidSymbol Method (ForgeTypeId, ForgeTypeId)


Format Options Is Valid Symbol(Forge Type Id, Forge Type Id) Method

Checks whether a symbol is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidSymbol(
	ForgeTypeId unitTypeId,
	ForgeTypeId symbolTypeId
)

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.
symbolTypeId ForgeTypeId
Identifier of the symbol to check.

Return Value

Boolean
True if the symbol is valid, false otherwise.
Exceptions
Exception Condition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
See Also